Canon 1D X Mk II Owners Thread

Messages
1,234
Name
Tony
Edit My Images
Yes
Juts found AWB White priority... how have I only just found this... not tried it proper but sounds just the ticket for my stuff..
I've never tried it, let me know if it works.
I customarily use ambience priority, not that it matters much with raw files.
 

KIPAX

Seriously Likeable
Messages
20,281
Name
KIPAX
Edit My Images
Yes
I've never tried it, let me know if it works.
I customarily use ambience priority, not that it matters much with raw files.

never tried raw on my 1dx cameras... love anti flicker.. add white priority to my armour.. for the really horrible places i go to.. ..will see what happens :) might give it a go around the house later.. no thats not one of the horrible places :)
 

JohnBradbury

A jolly good egg!
Messages
784
Name
John
Edit My Images
Yes
Evening all. I’m wondering whether or not it’s possible to tether to an iPhone or iPad (for video or stills)? I’m shooting a studio night with my camera club in a few weeks and i’d Really love to be able to preview the results.
 
Last edited:
Messages
2,401
Name
Chris
Edit My Images
Yes
The WFT-E8 (or if you can find a WFT-e6 on ebay) would allow you to wirelessly connect - but obviously a pricey option.
 
Messages
6,204
Name
Robin
Edit My Images
Yes
Evening all. I’m wondering wether or not it’s possible to tether to an iPhone or iPad (for video or stills)? I’m shooting a studio night with my camera club in a few weeks and i’d Really love to be able to preview the results.
....Surely an iPhone screen would be too small for viewing to be worthwhile whereas an iPad would be better and a laptop better still.

Can you not tether onto a laptop via software such Capture One (or even Lightroom?).
 

KIPAX

Seriously Likeable
Messages
20,281
Name
KIPAX
Edit My Images
Yes
Just bought some goodies to go with the new camera.

Can’t wait to use them.

Try the 70-200 at least with and without the filter at 70 and 200.... I ahve the 1dx2 and the 70-200II ..had a decent filter and it really wasnt worth it.. decreased the quality of pics... i wont have a uv filter on any lens.. your always going to decrease quality sticking extra glass in front.IMHO. the 70-200 suffered badly for me.. maybe not for you..

you ahve a lens hood on anyway so your not going to scratch owt :)
 
Messages
2,401
Name
Chris
Edit My Images
Yes
Strange I knew a guy who had 500k mileage on his first year of ownership and only died at 650k shutter. YMMV
It's related to water seepage into the body through a lens that allowed in much more water than it should.... the 100mm macro 2.8L isn't very weather sealed at all - even with its rubber gasket.... (I actually suspect water entered the lens via the focusing ring as it happens though)
 
Messages
2,424
Name
Stu
Edit My Images
Yes
Chris,is the camera repairable? It's terrible, reading of incidents like this........... I do hope you are covered in some way,and everything can be fixed. Was the offending lens the 100mm marcro with IS please or the cheeper non is version??

all the luck

stu
 
Messages
2,424
Name
Stu
Edit My Images
Yes
Guys do any of you use screen protectors , if so which please. i've got a giottos on my 1Div i'd like to do similar....................... if all pans out I should have a new(well ok secondhand but who cares i'm stoked) toy in me grubby mits soon

many thanks

stu
 
Messages
2,401
Name
Chris
Edit My Images
Yes
Chris,is the camera repairable? It's terrible, reading of incidents like this........... I do hope you are covered in some way,and everything can be fixed. Was the offending lens the 100mm marcro with IS please or the cheeper non is version??

all the luck

stu
It's been repaired :) I should be picking it up tomorrow - the lens is dead - that's the L version of the macro - 2.8 with IS - red ring. The camera has had the shutterbox replaced for the cost of around £300 - and they now say that'll be as good as new.
 
Messages
2,401
Name
Chris
Edit My Images
Yes
Guys do any of you use screen protectors , if so which please. i've got a giottos on my 1Div i'd like to do similar....................... if all pans out I should have a new(well ok secondhand but who cares i'm stoked) toy in me grubby mits soon

many thanks

stu
I just use a plastic style one that I got online - no particular supplier brand - not the tempered glass type. It stuck well enough, and the touch screen didn't appear to have been affected - and aside from the fact the insides got flooded - the screen itself has always been spot on!
 
Messages
2,424
Name
Stu
Edit My Images
Yes
Ahh mate I'm stoked for you it's a shame about the lens,but it's not quite so hard to replace as a 1DXii.

Cheers also on the screen protector advice. My very first outing with my first DSLR I got a foot wrapped in some bramble and ended up snagging the screen on barbed wire,so I'm very keen to get this aspect sorted. Chris the 550D had a simple soft plastic protector no doubt it helped. but I'd muchrather something akin to the giottos,I just can't find anything as yet in the UK

cheers for the replies,glad that camera is back up and running,you must be somewhat relieved

stu
 
Messages
3,334
Name
Gary
Edit My Images
No
Ahh mate I'm stoked for you it's a shame about the lens,but it's not quite so hard to replace as a 1DXii.

Cheers also on the screen protector advice. My very first outing with my first DSLR I got a foot wrapped in some bramble and ended up snagging the screen on barbed wire,so I'm very keen to get this aspect sorted. Chris the 550D had a simple soft plastic protector no doubt it helped. but I'd muchrather something akin to the giottos,I just can't find anything as yet in the UK

cheers for the replies,glad that camera is back up and running,you must be somewhat relieved

stu
I use LARMOR screen protectors on both my bodies. Easy to apply and no problems with either.
 
Messages
2,424
Name
Stu
Edit My Images
Yes
I use LARMOR screen protectors on both my bodies. Easy to apply and no problems with either.
'ello Gaz how ya doin'?

Mate I've come across these on an auction site could you give me a link please? Gaz reason being i'm curious as to whether you are using the magnetic screen "shade" device...'ern thingy:).but, also the fact that I'm seeing two bits of glass not three in many of those items,i've so far come across since reading your post.

Gaz,do lamor provide a three glass screeen protector set that doesn't include the shade device.??

Thanks for the help mate appreciated !!

stu
 
Messages
3,334
Name
Gary
Edit My Images
No
'ello Gaz how ya doin'?

Mate I've come across these on an auction site could you give me a link please? Gaz reason being i'm curious as to whether you are using the magnetic screen "shade" device...'ern thingy:).but, also the fact that I'm seeing two bits of glass not three in many of those items,i've so far come across since reading your post.

Gaz,do lamor provide a three glass screeen protector set that doesn't include the shade device.??

Thanks for the help mate appreciated !!

stu
Hi Stu

I’m ok thanks, hope all is good with you.

I got mine from dale Photographic

https://www.dalephotographic.co.uk/...75400466.html#product-description-tab-content

I just got the one for the rear lcd without the shade
 

Canon Bob

Loves the Enemy
Messages
10,426
Name
Bob
Edit My Images
Yes
I think that the MkII does generate a slightly warmer image. You could play with the WB shift and see if you can match them up.....there's a pretty good description here

(WB shift is the 3rd item on the first red menu page and on page 186 in the user guide)
 
Messages
2,424
Name
Stu
Edit My Images
Yes
Guys could you give me some advice please. I use orientation linked focus points,often times with the hares and close I need to swap from one to the other orientation very fast,this saves me a click or two. I noticed yesterday a focal point for lack of a better phrase was part active. so when I moved points this one was almost still part engaged quite probably the one i'd last used. It seemed to be there with both orientations,i'm not sure if the exact point.

i'd actually met some friends yesterday whom shoot1 DXii and we had a chat around the AF menu adjusted the orientation linked FP's both to center problem seemed solved. It's back again today. I can't work out whether i'm just being stupid and have somehow adjusted something inadvertantly or I have a fault. I thought it best to ask for your wisdom first. Then I was thinking of a factory reset if I can't pin it down to me and set up again. ?? Guys I can't read alot at the mo few scary eye issues,forgive me bothering, I find trying to dig myself out first to be good for me as I need to constantly reinforce it's how I'm made,but I can't do my homework at the mo like I want to.

Oh incidentally referring to up there ^^^^ how do you guys view the AWB ambiance preset for colour my 1div was never as close as that preset is for me WB wise I still tweak but it seems a much closer base to what I see in life

take care

thank you :)

stu
 
Messages
6,204
Name
Robin
Edit My Images
Yes
Guys could you give me some advice please. I use orientation linked focus points,often times with the hares and close I need to swap from one to the other orientation very fast,this saves me a click or two. I noticed yesterday a focal point for lack of a better phrase was part active. so when I moved points this one was almost still part engaged quite probably the one i'd last used. It seemed to be there with both orientations,i'm not sure if the exact point.

i'd actually met some friends yesterday whom shoot1 DXii and we had a chat around the AF menu adjusted the orientation linked FP's both to center problem seemed solved. It's back again today. I can't work out whether i'm just being stupid and have somehow adjusted something inadvertantly or I have a fault. I thought it best to ask for your wisdom first. Then I was thinking of a factory reset if I can't pin it down to me and set up again. ?? Guys I can't read alot at the mo few scary eye issues,forgive me bothering, I find trying to dig myself out first to be good for me as I need to constantly reinforce it's how I'm made,but I can't do my homework at the mo like I want to.

Oh incidentally referring to up there ^^^^ how do you guys view the AWB ambiance preset for colour my 1div was never as close as that preset is for me WB wise I still tweak but it seems a much closer base to what I see in life

take care

thank you :)

stu
Hi Stu,

I haven't experienced your problem but if moving from landscape to portrait orientation I always have the duplicated set of buttons switched to ON and for a portrait shot I'm only going to be using the central AF points active anyway. I only switch to AF zones when I use AI SERVO for action shots, otherwise I am in ONE SHOT and using AF-ON button for Back Button Focus. This probably doesn't help you, sorry!

Perhaps check that your 1DX-2 firmware is the latest available? If that provides a solution it will have been easier than resetting all your customised settings to Canon default. The firmware latest is 1.1.6.

On the subject of colour balance, Canon's 'colour science' as it's often called, is considered to be probably the best but we each see colours slightly differently with the naked human eye. Try setting your 1DX-2 Picture Style to Neutral?

If you shoot RAW, colour balance is very easily adjusted to your taste in post-processing but I'm thinking that if you have eye issues currently you would probably want to minimise your computer work.
 
Messages
6,204
Name
Robin
Edit My Images
Yes
A QUESTION FOR 1DX-2 USERS WHO ALSO USE MACS PLEASE :

I have CFast 2.0 and CF cards loaded, both SanDisk Extreme PRO 64GB. I only record RAW and to the CFast card with the CF card for overflow (which is rare).

My Macs are an iMac and a MacBook Pro, both running macOS High Sierra 10.13.6. I connect to upload images into Apple's Image Capture via the Canon supplied USB cable. My iMac only has USB-2 whereas my laptop has USB-3 ports.

The problem is that Image Capture rarely sees/loads the files from my camera's CFast card, although randomly '1 time out of 20' it occasionally does. So my workaround is to first copy ('Transfer' in the blue Menu) all the image files from the CFast to the CF card within the 1DX-2 while it is switched off and disconnected, and then the CR2 files can arrive on my Mac. The problem also existed when both my Macs were running the previous OS.

I always religiously reformat both cards before using my camera again.

The only reason I can think of is that the macOS does not support CFast cards? Any suggestions or help would be appreciated.

Thanks,
Robin
 
Messages
2,424
Name
Stu
Edit My Images
Yes
Hiiya Robin,cheers for the reply very interesting although sadly not terribly helpful to my problems and sadly I can't help( non mac user) you eithe:( . I do shoot RAW Robin so yes WB easily tweaked,i'm just stunned by how good the colours seem to me 'erm eye in the 1DXii. I didn't normally use the presets with my 1div, always shot in daylight and adjust eyedropper or colour temp. But the awb ambiance seems to give me a much better start point where I don't always feel a need to tweak WB with the DXii

Always cool hearing how another approaches shooting though Robiin,in portrait I am invariably close,so my subjects head is almost always in the higher reaches of the frame,,my hares are the worst (up close) because of their shape and their habbit of stopping briefly to sit up,so the flipping of a camera fluently is an incredibly important skill set for me to aquire, The FP landing some where towards the head saves me splits of a second enabling me to hopefully catch a few more little nuances in expression,that can ellivate a frame or two in a set.

While talking to my friend it became clear that someone else had had a similar problem,but I believe was cured by moving the relevant bit in the AF menu.

Robin ,i'll check my filmware ;)
 
OP
OP
George

George

Chasseur Haggis extraordinaire
Messages
3,598
Edit My Images
Yes
Hi Robin,

I don't use the workflow you do, however I'm exclusively Mac and my MacBook Pro running High Sierrd doesn't have any problem seeing my CFast cards......I connect the card reader (CFast) to my laptop and also my master storage disc, and transfer images I want to the storage disc then import in to Lightroom......are you copying straight from the camera?...never done that....but not had any problems with seeing RAW files via the reader....or am I missing something?

George.
 
Messages
6,204
Name
Robin
Edit My Images
Yes
Hi Robin,

I don't use the workflow you do, however I'm exclusively Mac and my MacBook Pro running High Sierrd doesn't have any problem seeing my CFast cards......I connect the card reader (CFast) to my laptop and also my master storage disc, and transfer images I want to the storage disc then import in to Lightroom......are you copying straight from the camera?...never done that....but not had any problems with seeing RAW files via the reader....or am I missing something?

George.
.... Thanks George.

Yes I do copy straight from camera via USB cable as I prefer if possible to leave my cards inside the camera body chamber but I don't have a CFast card reader anyway. Can you recommend one please? I don't mind the cost and don't want a cheap-as-chips unreliable one.
 
OP
OP
George

George

Chasseur Haggis extraordinaire
Messages
3,598
Edit My Images
Yes
Hi Robin, about to go out for a few hours....think mine was Lexar but will check later today if thAT'S OK!!
 
Top