Electrical contact problem ??

Messages
216
Name
Peter
Edit My Images
Yes
Just acquired a Nikkor AF-S 500mm F4 D and have what seems a leccy contact issue with one of my 2 Nikon bodies.
The lens works fine on my D7000, but wont make contact on my D7500. I've got the dreaded F EE in the viewfinder / info screen.

Strangely, all my other lenses ( Nikkor, Tamron, Tokina, Sigma ) work fine on the D7500. In fact, i've just recently taken off my Sigma 300-800 F5.6, which was working beautifully.

Of course, i have cleaned the contacts on both 500 F4 and D7500, but since every other lens i have works fine, and also the 500 works fine on my D7000, i'm finding it hard to accept its the contacts.

The lens locks in place just fine
 
Last edited:
OP
Tonto
Messages
216
Name
Peter
Edit My Images
Yes
You think its possible that the D7500 needs a firmware update ? Never thought of that.

Nikon UK are closed right now despite support being open to 5pm. Even the voice message says sorry we are closed, we open from to 9 to 5

I suspect that some forgot to change the answer machine message
 
OP
Tonto
Messages
216
Name
Peter
Edit My Images
Yes
Changes from “C” Firmware Version 1.01 to 1.10

Just seen that 1.10 is the latest FW and my camera already has this version
 
OP
Tonto
Messages
216
Name
Peter
Edit My Images
Yes
Have you set the aperture lock (minimum aperture)?

Yup, set and locked
 
OP
Tonto
Messages
216
Name
Peter
Edit My Images
Yes
Ok thanks
 
OP
Tonto
Messages
216
Name
Peter
Edit My Images
Yes
Downloaded the viewer and there appears to be no issues of compatibility with AF-s 500 f4 IFED and D7500.

I fear the worst
 
Messages
37,212
Edit My Images
No
Did you get the 'click' when the lens was fitted?
Maybe twist slightly to left and right to see if it just needs aligning better.
 
OP
Tonto
Messages
216
Name
Peter
Edit My Images
Yes
It locks in just fine like all my other lenses on that body. Twisting back and forth a tiny fraction does nothing at all, sadly :(
 
OP
Tonto
Messages
216
Name
Peter
Edit My Images
Yes
Its not the D7000 , i already said the lens is fine with that. Its the D7500 we're on about. There's no TC involved


The lens works fine on my D7000, but wont make contact on my D7500. I've got the dreaded F EE in the viewfinder / info screen.
 
OP
Tonto
Messages
216
Name
Peter
Edit My Images
Yes
Yeah i know its compatible with the D7000, because i already mentioned that in the first post and have already checked online

I cannot test the D7000 with a TC as i dont own one. Be nice to try though
 
OP
Tonto
Messages
216
Name
Peter
Edit My Images
Yes
I know - i already posted that. Did you read the thread from the start ?

Downloaded the viewer and there appears to be no issues of compatibility with AF-s 500 f4 IFED and D7500.
 
Messages
56
Name
richard
Edit My Images
Yes
Not clear whether you were implying that Nikon Service in Kingston was closed in lockdown or just the phone lines had closed for the day.

If its any use, I found that mailing them got a reasonably quick response - they often pass tech queries on to Nikon Europe ( at least they did with my Z6 and a Nikon V1 earlier ). Once you get contact with an engineer directly they move pretty fast.

Good luck with this - hope you can get it sorted !
 
OP
Tonto
Messages
216
Name
Peter
Edit My Images
Yes
Thanks - it seems they were closed an hour early.

I'm really stumped now, so that's the next step
 
OP
Tonto
Messages
216
Name
Peter
Edit My Images
Yes
I'm afraid i dont know anyone with a D7500 apart from me. :D
 
Top