Sigma 70-300 stopped autofocusing?

Messages
316
Name
Scott
Edit My Images
Yes
I have a Sigma 70-300 F4-F5.6 DG Macro lens which i bought 2 years ago. I went to use it the other day but there is no autofocus action working on it at all. It manual focuses fine, which to me, means the gears are not blocked, but even when i tried it in another camera body last night, the autofocus did not move at all.

I wondered if anybody on here has experienced this and, besides suggesting I buy a new one ( I can't, I am just about to move house so all my money is tied up in that for a while), does anybody have any suggestions on how I can fix it?
Thanks :)
 
OP
sc0ttie
Messages
316
Name
Scott
Edit My Images
Yes
Yes I have cleaned them with a lens cleaning cloth.
 
Messages
10,457
Name
Suz
Edit My Images
Yes
I'd contact sigma. It might still be under warranty as they started offering 3 year ones on a lot of their lenses.
 
OP
sc0ttie
Messages
316
Name
Scott
Edit My Images
Yes
I'd contact sigma. It might still be under warranty as they started offering 3 year ones on a lot of their lenses.
Thanks, if nobody else has any other suggestions I might just do that.
 
Messages
10,202
Edit My Images
No
Check the switch, check the push-pull on the focus ring (I think this lens has that).. both obvious, but sometimes too obvious..
 
Messages
1,511
Name
Jonathan
Edit My Images
Yes
Note sure if this is applicable to the Nikon version, but on the Sony mount version the AF gears were known to be made of plastic, and could sometimes break - leaving the lens as MF only. If this happened you would hear a distinctive noise when AF was attempted, as a gear tried to turn the missing teeth.
 
Messages
1,315
Name
rab
Edit My Images
No
i have the same lens i think is it the apo? the switch is a known issue on them from what i can rem try wiggling the switch about
 
OP
sc0ttie
Messages
316
Name
Scott
Edit My Images
Yes
I have tried moving the switch a bit but no luck. I bet it is the switch. Camera still meters in auto with the lens but when pressing the shutter button to get it ti autofocus the LCD screen goes off and comes back on once the shot it taken. In both manual and autofocus modes.
 
Top