1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Don't forget to change the clocks on your camera equipment!

    Dismiss Notice
  3. It is with great sadness that we announce the passing of a long-standing member, Just Dave.

    Dave Barker was a member of Talk Photography for nearly 10 years, and was a prominent member for most of those.
    A very warm, friendly and enthusiastic member, he spent the largest portion of his time on TP welcoming and helping others.

    I'm sure all visitors to this site will join us in thanking Dave for his unwavering support and being a large part of our community.
    Our thoughts are with his family and friends at such a difficult time.

    Click here to join in the discussion

    Dismiss Notice
  1. NickTB

    NickTB

    Messages:
    1,589
    Name:
    Nick
    Edit My Images:
    Yes
    Afternoon all. I bought a 27" iMac with 3.2ghz 16gb ram amd Radeon m9 and a 256 ssd with 1tb hard drive a month or so ago.
    Using LR6 and PS was like dragging a sticky thing through molasses. So Apple picked up the old one and replaced it with a sparkly new one of the same spec. This worked well for 2-3 days and it's gone the same way.
    I can get a full refund under Apples 30 day return, but then what? What kind of pc and monitor can I get with the same or better spec and importantly for me the same customer service that Apple provides should I have a problem with a pc?
    As you may be able to tell, I'm frustrated as I'm an Apple fan boy but this can't continue.

    Any advice would be welcomed.

    TIA
    Nick
     
  2. wolfyccfc

    wolfyccfc

    Messages:
    159
    Name:
    Martin
    Edit My Images:
    No
    I have a 27" i5 my13 and it was fine until I installed adobe creative cloud, it's still fine but for the first 10-15 mins whilst the creative cloud loads it is dog slow. Is it slow at all times?
     
    SsSsSsSsSnake and NickTB like this.
  3. NickTB

    NickTB

    Messages:
    1,589
    Name:
    Nick
    Edit My Images:
    Yes
    To be honest I only use it for LR and PS so I'm not sure. The only other thing I do is browse the web. All of my photos are on an external hard drive. I do have creative cloud though
     
  4. gremlin16

    gremlin16

    Messages:
    863
    Edit My Images:
    Yes
    How is the external drive connected? That could be the choke point. I'm no expert I must add.
     
  5. NickTB

    NickTB

    Messages:
    1,589
    Name:
    Nick
    Edit My Images:
    Yes
    Via USB directly to the machine
     
  6. sphexx

    sphexx

    Messages:
    660
    Name:
    Richard
    Edit My Images:
    No
    Does the hard drive have USB 3?
     
  7. NickTB

    NickTB

    Messages:
    1,589
    Name:
    Nick
    Edit My Images:
    Yes
    Sorry, yes it does
     
  8. ecoleman

    ecoleman

    Messages:
    3,116
    Name:
    Elliott
    Edit My Images:
    Yes
    Turn off GPU acceleration. It's useless and slows my Mac down.
     
  9. ecoleman

    ecoleman

    Messages:
    3,116
    Name:
    Elliott
    Edit My Images:
    Yes
    Whilst the creative cloud loads??
    Nothing loads from the cloud.
     
  10. wolfyccfc

    wolfyccfc

    Messages:
    159
    Name:
    Martin
    Edit My Images:
    No
    The module loading,
     
  11. ecoleman

    ecoleman

    Messages:
    3,116
    Name:
    Elliott
    Edit My Images:
    Yes
    Sorry, still not sure what you're referring to.
     
  12. wolfyccfc

    wolfyccfc

    Messages:
    159
    Name:
    Martin
    Edit My Images:
    No
    Basically until the creative cloud is fully loaded which takes around 10minutes mine is dog slow. For around 10 minutes the icon for creative cloud on the top row is greyed out.
    I took it to the Apple Store recently as I had the hinge break issue and the guy who dealt with me had the same issue with the creative cloud, he said to uninstall and then download again but it didn't work for me. Have also tried disabling the fonts with no joy which is mentioned on various forums.
     
  13. ecoleman

    ecoleman

    Messages:
    3,116
    Name:
    Elliott
    Edit My Images:
    Yes
    My creative cloud app loads on boot and logs in automatically. It's also not required to be running or logged in, in order to run PS or LR.
     
    Nostromo likes this.
  14. Nostromo

    Nostromo

    Messages:
    849
    Name:
    Dominic
    Edit My Images:
    Yes
    Even when i used to use my old, old laptop, that only had 4g ram and an intel dual core cpu, the cc app would load pretty quickly. It sounds like you have other issues that are creating your problems. Although I am not particularly techie so could be wrong.
     
  15. Livin The Dream

    Livin The Dream

    Messages:
    2,601
    Name:
    Kris
    Edit My Images:
    No
    There must be something else going on here, my MBP works flawlessly with very little drag with CC. Can you not monitor CPU usage somehow, you probably can identify it someway?
     
    NickTB likes this.
  16. NickTB

    NickTB

    Messages:
    1,589
    Name:
    Nick
    Edit My Images:
    Yes
    I agree. So many people use mbp's for editing there it should be ok on this spec. I did a diagnostics with Apple over the phone with no joy. Just about to speak to Apple tech again
     
    Livin The Dream likes this.
  17. Livin The Dream

    Livin The Dream

    Messages:
    2,601
    Name:
    Kris
    Edit My Images:
    No
    It should be blindingly quick with that spec!
     
  18. NickTB

    NickTB

    Messages:
    1,589
    Name:
    Nick
    Edit My Images:
    Yes
    I cleared the RAM and it seems to have sparked onto life. Photoshop is incredibly quick. Will reinstall LR tonight to see whether that's made a difference
     
  19. minnnt

    minnnt

    Messages:
    17,887
    Name:
    David
    Edit My Images:
    Yes
    How do you clear the RAM?
     
  20. NickTB

    NickTB

    Messages:
    1,589
    Name:
    Nick
    Edit My Images:
    Yes
    Shut down the machine, restart holding command/option/p/r and it reboots making two start up sounds one after the other

    This was all on the phone with a tech. I was sceptical, but it seems to have worked. No lag at all in PS
     
    minnnt likes this.
  21. SsSsSsSsSnake

    SsSsSsSsSnake

    Messages:
    4,103
    Name:
    Chris
    Edit My Images:
    Yes
  22. holty

    holty

    Messages:
    2,796
    Edit My Images:
    No
    :plus1:
     
  23. Furtim

    Furtim

    Messages:
    1,049
    Name:
    David
    Edit My Images:
    Yes
    Ah okay. That clears the PRAM, basically a small amount of memory that holds confit details about your system. If this gets corrupted it can trick your system into trying to work in a way it shouldn't (perhaps thinking it has more memory than it really has etc).

    Perfectly safe to do and a good first step in troubleshoooting odd issues with the Mac
     
    SsSsSsSsSnake likes this.
  24. minnnt

    minnnt

    Messages:
    17,887
    Name:
    David
    Edit My Images:
    Yes
    Thanks, good tip. (y)
     
  25. NickTB

    NickTB

    Messages:
    1,589
    Name:
    Nick
    Edit My Images:
    Yes
    Come to think of it, the Tech did call it PRAM
     
  26. minnnt

    minnnt

    Messages:
    17,887
    Name:
    David
    Edit My Images:
    Yes
    There's also the SMC which can be reset by turning unplugging the Mac from the wall and holding the power button for 5 seconds.

    Not that I'm having issues but I'm curious to give it a go now. Haha.
     
    NickTB likes this.
  27. Steve27752

    Steve27752

    Messages:
    11
    Name:
    Steve
    Edit My Images:
    Yes
    I truly wish that i could understand what you are all talking about:rolleyes:
     
    Carl Hall, SsSsSsSsSnake and NickTB like this.
  28. NickTB

    NickTB

    Messages:
    1,589
    Name:
    Nick
    Edit My Images:
    Yes
    I only know any of this because I've spent so long talking to Apple techs!
     
    SsSsSsSsSnake likes this.
  29. sphexx

    sphexx

    Messages:
    660
    Name:
    Richard
    Edit My Images:
    No
    As mentioned above, Memory Clean is a good utility. I use it routinely after using Safari (lots of tabs) which is bad at releasing RAM when it shuts down.
     
    SsSsSsSsSnake likes this.
  30. Livin The Dream

    Livin The Dream

    Messages:
    2,601
    Name:
    Kris
    Edit My Images:
    No
  31. SsSsSsSsSnake

    SsSsSsSsSnake

    Messages:
    4,103
    Name:
    Chris
    Edit My Images:
    Yes
    Hi Kris but the secret is to keep doing it i can virtually get to within about 2 gig of my 16 gig ram ,takes about 5 x to do it, only takes about 5 mins
     
    Livin The Dream likes this.
  32. SsSsSsSsSnake

    SsSsSsSsSnake

    Messages:
    4,103
    Name:
    Chris
    Edit My Images:
    Yes
  33. SsSsSsSsSnake

    SsSsSsSsSnake

    Messages:
    4,103
    Name:
    Chris
    Edit My Images:
    Yes
    Last edited: Apr 20, 2017 at 12:15 AM
  34. TonyHall

    TonyHall

    Messages:
    318
    Edit My Images:
    No
    But it takes less than a minute to simply reboot the computer (restarting can automatically reopen all the apps and windows open at time of selecting 'Restart...').
    (Or am I missing something mind-boggingly obvious?)
     
    SsSsSsSsSnake and sphexx like this.
  35. SsSsSsSsSnake

    SsSsSsSsSnake

    Messages:
    4,103
    Name:
    Chris
    Edit My Images:
    Yes
    Not my 2011 mac,it takes an age now
     
  36. SsSsSsSsSnake

    SsSsSsSsSnake

    Messages:
    4,103
    Name:
    Chris
    Edit My Images:
    Yes
    Plus rebooting doesnt fix file corruption issues etc
     
  37. NickTB

    NickTB

    Messages:
    1,589
    Name:
    Nick
    Edit My Images:
    Yes
    Just as an update, I've reinstalled LR and the problem persists. Photoshop seems fine, but LR is dog slow. Every change I make manifests itself in blocky rendering. So back on the phone to Apple support I go
     
  38. minnnt

    minnnt

    Messages:
    17,887
    Name:
    David
    Edit My Images:
    Yes
    Have you turned off the GPU rendering thingy me whatsit in the menu?

    @ecoleman has mentioned this several times in other threads, perhaps it's worth a look.
     
  39. minnnt

    minnnt

    Messages:
    17,887
    Name:
    David
    Edit My Images:
    Yes
  40. NickTB

    NickTB

    Messages:
    1,589
    Name:
    Nick
    Edit My Images:
    Yes
    Yeah I tried that, it made no difference. Really frustrating
     

Share This Page