Nikon D3S Fault

Messages
1,829
Name
Adrian
Edit My Images
Yes
Noticed this the last couple of times I have had it out:

It seems to freeze, even when I turn off and back on it does not turn off. The only way to 'reset' is to remove and re-insert battery which brings it back to normal. When it freezes, it is fully unresponsive. Does the same with different lenses. Probably had to pull the battery out 10 times in an hour the other day to continue using.

Anyone experienced this problem on this model before? Suspect it may be a dry joint somewhere on the board so unsure how repairable this would be...........

Thanks.
 
Messages
5,982
Name
Dave
Edit My Images
No
Messages
3,164
Name
Allen
Edit My Images
Yes
Well Well Well , I am never to old to learn , I did not know this so thanks for sharing
 
OP
Ady N
Messages
1,829
Name
Adrian
Edit My Images
Yes
Just tried it - never knew that. Took a few shots and it froze again though....................
 
Messages
3,164
Name
Allen
Edit My Images
Yes
Have you tried it with a different lens , battery, memory card ?
Cleaned the lens mount contacts etc ?
 
Messages
37,415
Edit My Images
No
Have you tried using a different battery and memory card(s) ... depending on the result you may be able to narrow the problem down to being a bad card or battery.
 
Last edited:
OP
Ady N
Messages
1,829
Name
Adrian
Edit My Images
Yes
Yes, have swapped out all swapable bits which is why I am suspecting some sort of fault on the board. I can still use it, just have to quickly disengage battery and then I can continue. Time between freezes varies - not ideal and may get worse...............
 

Nod

Krispy
Messages
37,307
Name
Nod (NOT Ethel!!!)
Edit My Images
Yes
Not got a copy of that manual (but I'll bet it's available online).
 
OP
Ady N
Messages
1,829
Name
Adrian
Edit My Images
Yes
Current version is 1.01. Will give that a go, thanks.
 
OP
Ady N
Messages
1,829
Name
Adrian
Edit My Images
Yes
Well well well. Just been using it on and off for over 1 hour and not 1 issue since I did the firmware update! Coincidence or cure?? Thanks for the tips, appreciated.
 
Messages
37,415
Edit My Images
No
Well well well. Just been using it on and off for over 1 hour and not 1 issue since I did the firmware update! Coincidence or cure?? Thanks for the tips, appreciated.
Glad it worked for you :)
 
Messages
37,415
Edit My Images
No
I would have to guess coincidence.
I can't see firmware released over 4 yrs ago for minor fixes rectifying what seems to be a pretty significant issue that has just recently developed... but hopefully I'm wrong.
Just the 'kick' it needed to restore equilibrium would be my guess. :)
 
Messages
1,085
Name
Paul
Edit My Images
No
Noticed this the last couple of times I have had it out:

It seems to freeze, even when I turn off and back on it does not turn off. The only way to 'reset' is to remove and re-insert battery which brings it back to normal. When it freezes, it is fully unresponsive. Does the same with different lenses. Probably had to pull the battery out 10 times in an hour the other day to continue using.

Anyone experienced this problem on this model before? Suspect it may be a dry joint somewhere on the board so unsure how repairable this would be...........

Thanks.
This has happened a couple of times with my D750. Same thing, only way to “fix” it is to remove the battery.
 
Top