Problem with Canon CR2 files

sirch

Official Forum Numpty 2015,FPOTY 2020
Messages
10,445
Name
Chris
Edit My Images
Yes
I was browsing through some images from a few years ago and noticed that a number of them show this issue:

CR2-issue.jpg

The curious thing is that the thumbnail looks fine and when I open the image it looks OK for a moment and then the problem shows up. It's not all CR2's not even those from the same day. I have tried on 3 monitors and two computers and it is consistent.
 
Messages
2,188
Name
Brian
Edit My Images
Yes
I've had a similar problem.

Easily rectified by reinstalling them from my backup.
 
Messages
2,188
Name
Brian
Edit My Images
Yes
You mean you don't have a backup?
 
Messages
10,940
Edit My Images
No
Yonks ago I had something similar with a Canon........might have been my 350D.

Whatever it was, i solved it by downloading again from the CF card. There was a corruption of the file during transfer.........I got rid of the card reader for another one!

As for the behaviour you are seeing, without knowing what software you are using.....I surmise it is upon 'looking' at the file initially showing the embedded (preview)jpeg, once it is ready it displays the actual CR2 raw file.

If it is indeed a file corruption then IMO it is irretrievable.....hence check your back up copy......but if that backup is simply a copy of what you imported originally then likely it is also affected.

PS and FWIW that is why I don't wipe my memory cards until I have confirmed that all image files are good!
 
Messages
2,188
Name
Brian
Edit My Images
Yes
If it is indeed a file corruption then IMO it is irretrievable.....hence check your back up copy......but if that backup is simply a copy of what you imported originally then likely it is also affected.

PS and FWIW that is why I don't wipe my memory cards until I have confirmed that all image files are good!
I think the OP is referring to image files that have previously displayed correctly.
My download procedure is; Download from card, Verify and Add Title, Caption and Keywords, THEN make at least two backups to USB connected external drives.
 
Last edited:
Messages
5,057
Edit My Images
No
If it's corrupt and there's no backup, the best you may be able to do is extract the thumbnail image itself, which might be adequate for web use etc. ExifTool is one application that does this.
 
Messages
10,940
Edit My Images
No
I think the OP is referring to image files that have previously displayed correctly.
My download procedure is; Download from card, Verify and Add Title, Caption and Keywords, THEN make at least two backups to USB connected external drives.
Fair point but IMO not clear especially when I read his paragraph re: tried on 2 different computers ;)

I have come across transfer corruption but never to date mention of corruption of an older stored file.

PS and in the past he was only checking by an image browser it more than likely he was viewing the embedded jpeg not the raw file!
 
Last edited:
OP
sirch

sirch

Official Forum Numpty 2015,FPOTY 2020
Messages
10,445
Name
Chris
Edit My Images
Yes
I do have several backups, I was just teasing Brian given his "easily rectified" response. The thing is that the photos were fine last time I looked, which may be a while ago, a year or more, not all images are affected and if I restore them from back up will the same thing happen, indeed, given the length of time, if the file has actually changed on disk then the backup will have picked up the change including the corruption.

I have looked at the above file on back-up and it renders OK from there but as I said, unless I get to the root cause I'm not convinced that it won't happen. Anyway thanks for the responses.
 
Messages
348
Edit My Images
No
What program are you using to view the photos?

If you have Windows have you tried downloading the latest codecs?
 
OP
sirch

sirch

Official Forum Numpty 2015,FPOTY 2020
Messages
10,445
Name
Chris
Edit My Images
Yes
What program are you using to view the photos?

If you have Windows have you tried downloading the latest codecs?
Thanks for the link but I see it in both LR and Windows Photo viewer so I'm not sure that fixing Photo viewer will help unless LR uses Photo viewer behind the scenes. I also see the problem on two different PCs and not on every photo. As far as I can tell I am using the latest codec but I was thinking that may be uninstalling the codec if I can figure out how and then reinstalling might fix it.
 

4wd

Messages
2,536
Name
North York Moors
Edit My Images
Yes
When you see it flash up OK briefly it could be reading a sidecar thumbnail.
Trying a different viewer such as faststone might help.
 
Messages
348
Edit My Images
No
Thanks for the link but I see it in both LR and Windows Photo viewer so I'm not sure that fixing Photo viewer will help unless LR uses Photo viewer behind the scenes. I also see the problem on two different PCs and not on every photo. As far as I can tell I am using the latest codec but I was thinking that may be uninstalling the codec if I can figure out how and then reinstalling might fix it.
That is more concerning. I am no expert but I don’t think LR relies on Photo Viewer or the Microsoft codecs. Still probably worth reinstalling the latest codecs.

Have you tried viewing the files on a tablet if you have one?

Could your hard drive be damaged?

Could you try restoring a file from your back to a different drive?

Good luck.
 
Messages
2,188
Name
Brian
Edit My Images
Yes
I do have several backups, I was just teasing Brian given his "easily rectified" response. The thing is that the photos were fine last time I looked, which may be a while ago, a year or more, not all images are affected and if I restore them from back up will the same thing happen, indeed, given the length of time, if the file has actually changed on disk then the backup will have picked up the change including the corruption.

I have looked at the above file on back-up and it renders OK from there but as I said, unless I get to the root cause I'm not convinced that it won't happen. Anyway thanks for the responses.
Strange thing but this "half scrambled" effect only seems to be on .cr2 files. I have some raw files from my 30D which are over ten years old and I have had the experience with two or three.
As I said, easily restored from my backup, but I haven't revisited to see if they are still OK. More recently I have had the odd Sony ARW raw file which has developed an overall green cast, which is not only on the thumbnail but also in the image file itself. Once again, restored from backup.
 
Top