Canon 5D mkiii firmware update stuck at 9% - Help !,,

Messages
175
Name
John
Edit My Images
Yes
#1
Hi

Thought I’d update firmware before selling.....its stuck at 9%.
Tried different cards etc, formatted, SD and CF always gets to 9 and stops.
Camera gets warmish,going from 1.3.3 to 1.3.5.
I’m using a Mac to download the firmware.
Any ideas ?

Thanks
John
 
Messages
14,765
Edit My Images
No
#2
Dont use a Mac for camera FW updates in my experience.....

See if their are any drivers the update requires before applying the update.
 
Messages
1,472
Edit My Images
Yes
#6
there are a couple of posts about this happening on the net. but in the end they seem to keep trying and it goes through.
 
OP
OP
Johnraiders
Messages
175
Name
John
Edit My Images
Yes
#11
No lens on body to start, tried with a lens no difference. Will leave it a 9 see if it goes through.
Changed to fully charged battery.
 

Canon Bob

Loves the Enemy
Messages
10,314
Name
Bob
Edit My Images
Yes
#12
Now that you've got a lens on it, press the shutter/AF-on button when it stops at 9%
 
Messages
6,811
Edit My Images
No
#13
Failed update solution(s)
--------------------------------------------------------------------------------------------------------------------------------
https://support.usa.canon.com/kb/index?page=content&id=ART136286&cat=EF&actp=LIST

Though this is when a specific lens is attached still might have some relevance?

Description
Recovering from a failed firmware update procedure with the EOS 5D MkIII and EF 40mm f2.8 STM
Solution
For the EOS 5D MkIII

We have found that the EF 40mm 2.8 STM firmware update failure with the EOS 5D Mark III can occur if the camera has Battery Info Registered and if the Battery Info is checked right before the firmware update is applied.

To restart the firmware update please follow the below procedure.

1. Remove the battery from the camera and remove the lens from the body, do not remove firmware update card.

2. Reinsert the battery and in the camera's menu go to "SET UP3" and select "Battery info."

3. When the battery info is displayed press the "INFO." button found next to the MENU button to display registered batteries and select "Delete info."
NOTE: If "Register" is highlighted that means that no batteries are registered so you can proceed to step 5

4. Delete all registered battery info displayed.

5. Remove battery from camera and reattach 40mm lens

6. Reinsert battery, "Firmware update failed. Try updating again." should appear, select OK to proceed with firmware update. Please ignore Current Version 0.0.0. Update should complete as normal with no issue.

---------------------------------------------------------------------------------------------------------------------------
Hope you can get it sorted out OK
 

Canon Bob

Loves the Enemy
Messages
10,314
Name
Bob
Edit My Images
Yes
#14
Messages
1,222
Edit My Images
Yes
#19
Success ! Pressing AF and or shutter button got it to carry on. Settled on 1.3.4
Thanks for the help. Now it’s off to eBay.
Glad it worked! I've never had any problems with my Mac and firmware updates.

I've just updated my 5D3 and 5D4. I was interested to see the instructions differed slightly. One said no lens should be attached whereas it wasn't mentioned in the other. Also one said it should have a non automatic mode selected and there was no mention of this with the other. It made me realise, it's worth reading the instructions carefully even if you've done it before! Not saying this was your problem, but I almost pushed on without reading them!
 
OP
OP
Johnraiders
Messages
175
Name
John
Edit My Images
Yes
#20
Reading the instructions..... should’ve done that, I will from now on.
Of course a scammer bought it on EBay, so that was a waste of the listing, will have to wait for next ebay offer.
 
Top